Lost Web Console Password

Symptom

The password for the Web Console SuperAdmin account has been lost.

Cause

Administrators manage many solutions and neglect password management.

Resolution

Cloud-Managed Policy Servers

On-Premise Policy Servers

You can remove the SuperAdmin account and create a new SuperAdmin account to log in with.

  • Follow the below steps, as shown in the code box.
  • Log in to the Policy Server console directly or by SSH.
  • Check the SuperAdmin account name.
  • Enter Configuration mode.
  • Allow your current IP access the the Policy Servers internal Data-Server.
  • Set a password for the Data-Server
  • Enter shell mode.
  • Authenticate to access the Mysql database.
  • Remove the old SuperAdmin Account.
  • Exit terminal and reconnect via SSH
  • Create a new SuperAdmin Account.
genian> en

genian> show superadmin
genian# conf t

genian(config)# data-server access-list [IP accessing console]
genian(config)# data-server password [Password]
genian(config)# exit
genian# @shell

Genians$ mysql -p[Password] -A ALDER

mysql> delete from ADMIN where ADM_ID = '[username]';
mysql> delete from USER where USER_ID = '[username]';
mysql> exit

Genians$ exit
  • Re enter SSH connection to Policy Server to create new superadmin account.
genian> en

genian# conf t

genian(config)# superadmin [account name] [password] [email address]

Note

All super admin accounts must be deleted to generate a new super admin using this method.