Web Console login Failed

Symptom

Authentication fails, and the message "Your location is not authorized to access this" is displayed.

../_images/webconsole-login.JPG

Cause

  • The Policy Server controls access to Web Console with an Access list, which is specific to each administrative account.
  • Access List is managed by a SuperAdmin account under "Web Console IP", under the administrator tab of each individual account.
  • If the administrator's IP address is not in the "Web Console IP" list, the administrator can not access Web Console.

Resolution

Verify that you have another account to login to Web Console with User Management modify permissions.

Next:
  • Login to the WebConsole
  • Navigate to Management > User > Click the User that you try login > Click the Administrator tab
  • Confirm that the target IP is included in "Web Console IP1"
  • Add IP address if IP address is not included. Hosts, subnets or 0.0.0.0/0 for all are accepted values.

If you do not have a login account for the Web Console:

  • Follow the below steps, as shown in the code box.
  • Login to Policy Server Console directly or through SSH.
  • Enter Configuration mode.
  • Allow your current IP access the the Policy Servers internal Data-Server.
  • Set a password for the Data-Server.
  • Enter shell mode.
  • Authenticate to access the Mysql database.
  • Update the allowed IP for the desired admin account.
genian> en

genian# conf t

genian(config)# data-server access-list [IP accessing console]
genian(config)# data-server password [Password]
genian(config)# exit
genian# @shell

Genians$ mysql -p[Password] -A ALDER
Genians$ update ADMIN set ADM_ALLOWIP1 = '0.0.0.0/0' where ADM_ID = 'admin'
Genians$ exit