NAC에이전트 미동작

증상

노드 상태가 연결중 이고 에이전트가 실행 중이지만 관리WebUI에서는 에이전트가 다운으로 표시되는 증상

원인

에이전트는 정책서버로 2분에 한 번씩 Keep-alive 패킷을 전송하여 에이전트 동작 상태를 알려준다.

정책서버는 에이전트로부터 10분 동안 Keep-alive 패킷을 수신하지 못하였을 때 에이전트의 동작 상태를 미 동작으로 변경한다.

다음과 같은 상황은 에이전트의 Keep-alive 동작을 방해하여 동작중이지만 다운상태로 표시된다:

  1. 정책서버와 에이전트 사이 방화벽에서 패킷 차단

  2. PC내 백신프로그램에서 Keep-alive 패킷전송을 방해

  3. 하드디스크 변경으로 인한 에이전트 설치 불가

  4. 에이전트가 Keep-Alive 패킷을 생성하지 않는 것

해결방법

정책서버와 에이전트간 통신 확인

  • 에이전트와 정책서버간의 Keep-Alive 통신 확인

tcpdump -i eth0 host [PC IP] and port 3871
  • 정책서버와 에이전트 사이에 방화벽이나 타 보안솔루션에서 단말에서 발생하는 패킷이 존재하는지 확인

Keep-Alive 패킷이 감지되지 않는 경우

  • 에이전트 설치가 정상적으로 설치되지 않았을 경우 발생 가능하며 에이전트를 재설치 하는 방법으로 조치

  • 단말내 다른 보안제품으로 인하여 Keep-alive 동작을 할 수 없는 상태일 경우는 타 보안제품을 삭제하고 에이전트 재설치 방법으로 조치

  • (Windows) 에이전트가 Keep-Alive 패킷을 생성하고 보내는지 확인하려면 추가적인 디버그 설정이 필요
    • 레지스트리에서 HKEY_LOCAL_MACHINE\SOFTWARE\Geni\Genian\Option 또는 HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Geni\Genian\Option 을 찾습니다.

    • DWORD:DebugPrint (1) 추가 설정

Keep-Alive 패킷이 감지되는 경우

  • Agnet 설치나 정책 서버에 문제가 있을 수 있습니다.

  • 기타 케이스에서는 로그를 수집하여 기술지원

참조: NAC 디버그로그와 패킷 수집