Node is not displayed in Web Console

Symptom

Case 1: None of the nodes except the Network Sensor are visible in the network subnet where the Network Sensor is installed.

Case 2: Only some nodes are visible while other active nodes are not detected.

Cause

Genian NAC can not scan nodes when the switch port configuration is mismatched with the Sensor interface settings.

Additionally, remote device/node discovery can be impacted when Radius Accounting, endpoint agent, or external API are not functioning properly.

Resolution

Switch

  • Ensure that the port Genian NAC is on is properly configured to access the VLAN(s) you wish to monitor.
  • Only Standard access ports (untagged) and 802.1Q Trunk (tagged) ports are supported by Genian NAC.

Network Sensor

  • Check the interface settings by accessing the command line and using the command show interface eth[#]
  • Be aware that interface eth0 can only function when attached to an access port or in the presence of a native VLAN on a trunk port.
  • All tagged VLAN traffic can only be seen by a defined sub interface on that VLAN. For configuration, see: Adding And Deleting Network Sensors
  • Try to ping resources on the subnet from the network sensor to ensure a communication path exists.

If using a Virtualized Sensor

  • Ensure your hypervisor is properly configured to interface with the network and your switches. Hypervisors frequently require non-standard configurations to communicate across a LAN, or to accept traffic from a trunked interface.

Endpoint Agent

  • Without the presence of a Sensor, the agent may be used to register nodes.

See:

RADIUS

  • Without the presence of a Sensor, RADIUS Access-Request packets may be used to register nodes.

See RADIUS Section:

API

  • Without the presence of a Sensor, REST API may be used to register nodes.

See: