GN-SA-2021-003: Genian NAC - Multiple Log4j Vulnerabilities


  • Dec 20, 2021


  • High


Geinans has released updates that address multiple log4j vulnerabilities as detailed below.

Vulnerability Details (1)

CVE-2021-44228 - Log4j Remote Code Execution

Apache Log4j2 2.0-beta9 through 2.12.1 and 2.13.0 through 2.15.0 JNDI features used in configuration, log messages, and parameters do not protect against attacker controlled LDAP and other JNDI related endpoints. An attacker who can control log messages or log message parameters can execute arbitrary code loaded from LDAP servers when message lookup substitution is enabled. From log4j 2.15.0, this behavior has been disabled by default. From version 2.16.0, this functionality has been completely removed.

Vulnerability Details (2)

CVE-2021-44228 - Log4j Malicious Data Input

It was found that the fix to address CVE-2021-44228 in Apache Log4j 2.15.0 was incomplete in certain non-default configurations. This could allows attackers with control over Thread Context Map (MDC) input data when the logging configuration uses a non-default Pattern Layout with either a Context Lookup (for example, $${ctx:loginId}) or a Thread Context Map pattern (%X, %mdc, or %MDC) to craft malicious input data using a JNDI Lookup pattern resulting in a denial of service (DOS) attack. Log4j 2.15.0 makes a best-effort attempt to restrict JNDI LDAP lookups to localhost by default. Log4j 2.16.0 fixes this issue by removing support for message lookup patterns and disabling JNDI functionality by default.

Vulnerability Details (3)

CVE-2019-17571 - Log4j Deserialization of Untrusted Data

Included in Log4j 1.2 is a SocketServer class that is vulnerable to deserialization of untrusted data which can be exploited to remotely execute arbitrary code when combined with a deserialization gadget when listening to untrusted network traffic for log data. This affects Log4j versions up to 1.2 up to 1.2.17.

Affected Products

  • Genian NAC v5.0.43 or less
  • For LTS, Genian NAC v5.0.42 revision 101421 or less

Affected Components

  • Policy Server


The vulnerabilities contained in this advisory can be addressed by upgrading to version listed below:


  • None